Module 15 - LoginApp - Method not found: 'Void System.Security.Permissions.SecurityPermission..ctor(System.Security.Permissions.PermissionState)’. | Selenium C# Forum
20% Off Lockdown Learning Discount Avail now

Module 15 - LoginApp - Method not found: 'Void System.Security.Permissions.SecurityPermission..ctor(System.Security.Permissions.PermissionState)’.

D
Dan Good Post on 24/04/2020

Good afternoon All,

 

Hope you're well at this difficult time.

 

When attempting to run the first NUnit exercise in the course using the enclosed ExcelReader.cs and the Login.cs files, having installed NUnit 3, Selenium 3.4 DLLs, and NPOI v2.5.1 on VS 2019 Community.

 

I have tried to change the user access permissions in Windows both for the file, the folder, and the Drive of my Windows 10 virtual machine but I still get an error when I attempt to run the code with the default FireFox browser settings (and the Browser column not yet added to Data.xls)

 

When attempting to run my code from the TestExplorer I get the following error for each of the 4 tests:

 

Results

 

    1)  doLogin("","","")

      Duration: < 1 ms

 

      Message:

        OneTimeSetUp: System.MissingMethodException : Method not found: 'Void System.Security.Permissions.SecurityPermission..ctor(System.Security.Permissions.PermissionState)'.

 

 

Thanks very much for your time.

Kind regards

D
Dan Good Reply on 24/04/2020

P.S I have also tried running VS as Administrator