Resolving Errors | Selenium Webdriver Tutorial with c# |Selenium C# training
20% Mid August Discount Avail now

Selenium C# Training Forum

Resolving Errors

C
Christopher Ugochukwu Anajemba Post on 20/04/2019

Hello, 

I have been facing a problem while trying to build a framework (Hybrid) and ever since I have not been able to resolve it.

 

Problem: Whenever I build a framework to a certain stage I get to a point where I get this error as pasted below:

 

Severity Code Description Project File Line Source Suppression State
Error Unable to copy file "obj\Debug\GlobalHybridFramework.dll" to "bin\Debug\GlobalHybridFramework.dll". The process cannot access the file 'bin\Debug\GlobalHybridFramework.dll' because it is being used by another process. GlobalHybridFramework Build

Severity Code Description Project File Line Source Suppression State
Error Could not copy "obj\Debug\GlobalHybridFramework.dll" to "bin\Debug\GlobalHybridFramework.dll". Exceeded retry count of 10. Failed. The file is locked by: "testhost.x86 (17224)" GlobalHybridFramework Build

 

Please, what could be the cause of this error and how can I be able to resolve it? Thanks.

G

Instructor

gunjan Reply on 20/04/2019

Please close all the visual studio instances and reopen it again and then try again.

Let me know if you still face the same issue.

C
Christopher Ugochukwu Anajemba Reply on 21/04/2019

Hello Gunjan, 

Thanks for your quick reply. I tried exactly what u asked me to do but I got this error

 

1>------ Build started: Project: GlobalHybridFramework, Configuration: Debug Any CPU ------
1>E:\SeleniumFrameworks\GlobalHybridFramework\GlobalHybridFramework\Settings\GenericKeywords.cs(123,40,123,41): warning CS0162: Unreachable code detected
1> GlobalHybridFramework -> E:\SeleniumFrameworks\GlobalHybridFramework\GlobalHybridFramework\bin\Debug\GlobalHybridFramework.dll
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

After a while of that error i got same message same as my initial query. Could you help me pls. Thanks.

C
Christopher Ugochukwu Anajemba Reply on 22/04/2019

I have solved the error. The error was caused by the misspelling of a test case name. this prevented the recognition of data on the test explorer window. Thanks for looking into it for me though.