On entering the command allure Serve Allure_Reports an error The term 'allure' is not recognized as the name of a cmdlet | Selenium Python Forum
A
Arvind C Posted on 06/08/2020

I have entered--alluredir=C:\Allure\Allure_Reports in the Eclipse -->Window-->Preferences.

Text and JSON files are generated in C:\Allure\Allure_Reports

I navigate back to Allure folder and on running the command allure serve Allure_Reports an error "The term 'allure' is not recognized as the name of a cmdlet" is displayed.

Please refer to snapshot attached


J
Jaspreet Replied on 07/08/2020

Hey, 

There are two another ways you can access the reports if it is not showing report by directly going to the location

1. Open powershell from the start menu and then go to the location and give the command.

2. Open command prompt, write powershell in cmd and cmd will be turned into powershell, go to the location and hit the same command "allure serve foldername".

 

If this does not work, you need to remove the allure commandline from the environment variables and add it again. Restart your system and then use powershell or command prompt. For more information you may watch module 14- Pytest Allure Reports


A
Arvind C Replied on 08/08/2020

Hello,

Thanks for the Response. I tried the same steps as mentioned but still facing the same issue.

Is there any other way to overcome this issue or can i use any other reporting tool.

Thanks,

Arvind


J
Jaspreet Replied on 13/08/2020

Hey, 

Glad to know you tried all the steps, but if still the same error is coming then you have remove all the dependencies of allure from your system including the path variables and re-install it and give the system restart.


A
Arvind C Replied on 18/09/2020

Hello,

Thanks for the response. Now I am able to execute the command and Report is also displayed but no data is displayed in the report.

I am using the Allure Version 2.10.0

Please find the below snapshot

Responsive image


J
Jaspreet Replied on 18/09/2020

Hello, 

The reason for getting this kind of report shows that there are no XML reports in the given folder to be converted to HTML reports. Kindly please check the XML reports generated in the folder by clearing the existing files from there and look for fresh reports being generated or not.  


A
Arvind C Replied on 18/09/2020

Hello,

Thanks for the response. In the destination folder where the reports are generated only .txt and .json files are present. '.xml' files are not present.

Responsive image


J
Jaspreet Replied on 19/09/2020

Hello, 

That is fine if the .json and .txt files are there. May be you are giving the command to generate HTML reports inside the folder itself. For eg: In my case , the reports are generated in D:\Jaspreet\Reports this location. So the command that I will give on powershell will be at the location 

D:\Jaspreet and then command will have folder name in which reports are lying:

D:\Jaspreet -- allure serve Reports(just a example which needs to be followed)

 

If you will give the allure serve command inside the reports folder, then on powershell only you will see, Reports does not exists. Just try doing as the given scenerio above and the reports will be generated.


Related Posts